Pingcord - YouTube API is down – Incident details

All systems operational

YouTube API is down

Resolved
Degraded performance
Started 18 days agoLasted about 3 hours

Affected

Integrations

Degraded performance from 6:34 PM to 8:31 PM, Operational from 8:31 PM to 9:37 PM

YouTube

Degraded performance from 6:34 PM to 8:31 PM, Operational from 8:31 PM to 9:37 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    The YouTube API is currently working as expected however Google services are still experiencing widespread downtime issues. Pingcord is continuing to process YouTube events at this time but we will monitor the situation closely in case of any further downtime from YouTube.

  • Identified
    Identified

    We are seeing multiple reports from other apps & services that Google Cloud APIs (incl. YouTube API) are experiencing an outage at this time. We will save YouTube events and will hold them in our event queue until Google resolve their outage.

  • Investigating
    Investigating

    The YouTube API is returning a server error which is preventing Pingcord from processing YouTube events. Please note this is not an issue with Pingcord and we are attempting to identify a workaround until YouTube API services are working again.